swoole_config.h:22:2: 错误:#error "GCC 4.8 or later required"

确定系统 gcc 版本

cc -v
gcc -v

升级gcc [参考本站升级教程]

升级 gcc 后任然报此错

来swoole在linux上默认用的是cc,不是gcc,
而cc是gcc(旧版)的软连。备份了下原来的的gcc,在创建一个现有版本的软连接覆盖,这样就可以了

which cc
cp /usr/bin/cc /usr/bin/cc_bak
rm /usr/bin/cc
ln -s /usr/local/bin/gcc /usr/bin/cc
cc -v

点赞(1) 打赏

Comment list 共有 0 条评论

暂无评论

微信小程序

微信扫一扫体验

立即
投稿

微信公众账号

微信扫一扫加关注

发表
评论
返回
顶部